• Welcome to the 'New' myODIE.com Portal. Where we plug in your potential!

Minimum System Requirements

Minimum System Requirements

The Minimum System Requirements listed below, are in place to protect the “CLIENT” from being billed for support for more than the value of the actual equipment, if these requirements are not met.

  1. myODIE.com supports the following Desktop/Laptop/Tablet Minimum System Requirements: (Dependent on Operating Systems and number of applications)
    • Machines shall have ≥ 2.0 GHz AMD/Intel (i3 | i5 | i7) Processor
    • Machines shall have ≥ 8.0 GB of RAM
    • Machines shall have ≥ 500GB Hard Drive (except for Solid State Drives (SSD))
    • Machines shall have an Optical Drive (CD | DVD | BLU-RAY)
    • Machines shall have a Gigabit Network Interface Card or Wireless equivalent
  2. myODIE.com supports the following Server Minimum System Requirements: (Dependent on Operating Systems and number of services)
    • Machines shall have ≥ 2.0 GHz AMD/Intel (i3 | i5 | i7) Processor
    • Machines shall have ≥ 8.0 GB of RAM
    • Machines shall have ≥ 500GB Hard Drive (Using RAID Technulogy) (except for Solid State Drives (SSD))
    • Machines shall have an Optical Drive (CD | DVD | BLU-RAY)
    • Machines shall have a Gigabit Network Interface Card or Wireless equivalent
  3. myODIE.com supports the following Operating System Requirements:
    • Microsoft Windows XP (No Support)
    • Microsoft Windows Vista (No Support)
    • Microsoft Windows 7 Professional or higher (No Home Editions) (SUPPORT ENDS ON 06/01/2020)
    • Microsoft Windows 8/8.1 Professional (No Home Editions) (SUPPORT ENDS ON 06/01/2020)
    • Microsoft Windows 10 Professional (No Home Editions)
    • Windows Server 2003 (No Support)
    • Windows Server 2003 R2 (Any Edition) (No Support)
    • Windows Server 2008 (Any Edition) (No Support)
    • Windows Sever 2008 R2 (Any Edition) (SUPPORT ENDS ON 06/01/2020)
    • Windows Server 2012 (Any Edition)
    • Windows Server 2012 R2 (Any Edition)
    • Windows Server 2016 (Any Edition)
    • Windows Server 2019 (Any Edition)
    • Microsoft Foundation Server 2008 R2 or higher (SUPPORT ENDS ON 06/01/2020)
    • Microsoft Essentials Server 2008 R2 or higher (SUPPORT ENDS ON 06/01/2020)
    • Microsoft Small Business Server 2011 (SUPPORT ENDS ON 06/01/2020)
    • Mac OS X 10.13 High Sierra
    • Mac OS X 10.12 Sierra
    • Mac OS X 10.11 El Capitan
    • Mac OS X 10.10 Yosemite
  4. myODIE.com supports the following Microsoft applications and all 3rd party Windows-based applications such as:
    • Microsoft System Security
    • Microsoft Internet Explorer v.11.0
    • Microsoft Edge
    • Microsoft Office Products: (Word | Excel | PowerPoint | OneNote | Outlook | Access | Publisher | Skype for Business | VISIO)
      • Microsoft Office 2010 Home & Business or Higher (SUPPORT ENDS ON 06/01/2020)
      • Microsoft Office 2013 Home & Business or Higher (SUPPORT ENDS ON 06/01/2020)
      • Microsoft Office 2016 Home & Business or Higher
      • Microsoft Office for MAC 2010 (Macintosh) (Home & Business Only)
      • Microsoft Office for MAC 2016 (Macintosh) (Home & Business Only)
  5. myODIE.com supports an array of the following 3rd party Windows-based applications such as: (Just some of the major applications we support or do not support.)
    • Adobe Products
      • Acrobat Standard/Professional v.9.0 or higher
      • Acrobat Reader DC v.9.0 or higher
      • Adobe Flash Player v.11.0 or higher
      • Adobe Air v.3.0 or higher
      • Adobe Shockwave Player v.12.0 or higher
      • DO NOT SUPPORT ADOBE CREATIVE SUITE (ANY VERSION)(Photoshop | Dreamweaver | Fireworks | Flash | Illustrator | InDesign | After Effects | etc.)
    • Anti-Virus/Anti-Malware/Anti-Spyware Products:
      • PC Matic
    • Browser Products
      • Google Chrome
      • Internet Explorer
      • Micrsoft Edge
      • Safari v.11.0
    • CTERA Products
      • C200 CTERA Appliance
      • C400 CTERA Appliance
      • C800 CTERA Appliance
      • Cloud/Workstation/Server Agent Applications
    • Intuit Products
      • QuickBooks Retail Versions (Must be with (3) Years of Product Release Date)
      • QuickBooks Enterprise Versions (Must be with (3) Years of Product Release Date)
      • QUICKBOOKS POINT OF SALE NOT SUPPORTED
      • QUICKBOOKS ONLINE BACKUP NOT SUPPORTED
      • QUICKBOOKS PAYROLL NOT SUPPORTED
    • JAVA Products
      • JAVE Runtime Environment
      • JAVA Desktop Client Environment
    • Network Inventory Advisor v.3.0 or higher
    • Nuance Products
      • Dragon Medically Speaking v.12.0 or higher
      • Dragon Naturally Speaking v.12.0 or higher
      • PDF Creator v.8.0 and higher
    • Outlook Messenger
      • Outlook Messenger v.7.0 or higher (Windows or Macintosh)
      • Link Server Pro v.7.0 or higher (Windows Only) (All Plug-Ins)
    • TeamViewer v.15.0 or higher